PHP 5.3.x 架设WordPress报错解决方法

  • 时间:
  • 浏览:0

  当有些人 将php升级到5.3以上版本时,也不源码线程(什儿 wordpress、joolma)就会突然总出 没有 4个多警告:

Deprecated: Assigning the return value of new by reference is deprecated in XXXX file in line xx

   一阵一阵是在国外产品中大后该突然总出 什儿 问题图片图片,Wordpress 3.1.2以上版本会突然总出 。但机会有些人 将php版本换回旧版本就不必突然总出 什儿 状况,原应是:php5.3版本中废除了php中的”=&”引用符号,也过多想qq克隆好友 对象实例,直接用=引用即可。

什儿 :  

$this->module = &new Products();

修改:

$this->module = new Products(); 

即可,另外,机会你让你qq克隆好友 4个多实例,没有 就需用:

  1. PHP5对象qq克隆好友 是采用引用的最好的法律土办法。
  2. 需用在qq克隆好友 对象时加关键字 clone。
  3. 且机会在qq克隆好友 的过程中,想一同变更有些属性,则需用增加函数_clone(),来完成。

  不过小编不赞同什儿 做法,还是希望PHP开发者相当于应该在php.ini上加个选项,有挑选性的使用这功能,而后该完正阉割掉。

附:

PHP 5.3.x 中弃用的功能:http://www.php.net/manual/zh/migration53.deprecated.php

PHP 5.3.x 不向下兼容的变化:http://www.php.net/manual/zh/migration53.incompatible.php

Tags: php 5.3   wordpress  
责任编辑:190